ejercicio "la hora"

Ir abajo

ejercicio "la hora"

Mensaje por Emiliano Salazar el Miér Jul 19, 2017 10:14 pm

Hola juan como estas, queria ver si esta bien el codigo del programa.

El codigo lo pego por aca asi lo podes copiar y ver si tiene un error en tu pseint, porque estuve tratando de subir el archivo y este foro no me deja, si sabes como hacer avisa, saludos

Algoritmo reloj
Escribir "¿Que hora es?"
Escribir "Ingrese la hora en enteros"
definir n Como Entero
leer n
Escribir "ingrese los decimales"
definir d como real
leer d
m <- d * 60
v <- 0//la variable V son los dias, y le doy valor 0 al principio.
//Hay tres opciones para la hora, si es mayor, menor o igual a 24, y a partir de lo que ingresa el usuario el codigo revisa
//en que tipo de "si" encaja.
si n > 24 Entonces
mientras n > 24 Hacer
n <- n - 24
v <- v + 1
FinMientras
si n es distinto a 0 Entonces
mostrar "son ", v " dias, con ", n " horas y ", m " minutos"
sino
mostrar "son ", v " dias, con ", m " minutos"
FinSi
finsi
si n < 24 Entonces
Mostrar "son las ", n " horas, con ", m " minutos"
FinSi
si n = 24 entonces
v <- 1
mostrar "Es ", v " dia, con ", m " minutos"
FinSi
FinAlgoritmo

Emiliano Salazar

Mensajes : 1
Fecha de inscripción : 04/07/2017

Ver perfil de usuario

Volver arriba Ir abajo

Re: ejercicio "la hora"

Mensaje por Juan Smoes el Sáb Jul 22, 2017 12:52 am

buenas, no lo meti en el pseint, pero aca por ahi te va a saltar de todo un poco, analicemos.
"""si V es distinto a 0 Entonces
mostrar "son ", v " dias, con ", n " horas y ", m " minutos"
sino
mostrar "son ", N " HORAS, con ", m " minutos"
FinSi""""
***POSIBILIDADES, que N sea "5" entonces es distinto de 0. entraria el
mostrar "son ", v " dias, con ", m " minutos"
*******SIGUEINDO EL ALGORITMO, SI MANTENMOS N=5 ENTRA LO SIGUIENTE****
*******YA QUE N ES MENOR QUE 24*****

si n < 24 Entonces
Mostrar "son las ", n " horas, con ", m " minutos"

FinSi
si n = 24 entonces
v <- 1
mostrar "Es ", v " dia, con ", m " minutos"
FinSi

CON EL PRIMER SI YA BASTABA PARA DEFINIR SI PONIAS DIAS U HORAS
TE PUSE EN VERDE LO QUE MODIFICARIA, EN ROJO LO QUE ENTRA SI V ES DISTINTO DE 0 Y EN AZUL COMENTARIOS. ESPERO TE HAYA ACLARADO ALGO, SINO LO SEGUIMOS CHARLANDO PRO ACA!

Juan Smoes
Admin

Mensajes : 10
Fecha de inscripción : 03/07/2017

Ver perfil de usuario http://111kbj.activo.mx

Volver arriba Ir abajo

Re: ejercicio "la hora"

Mensaje por Juan Smoes el Sáb Jul 22, 2017 12:57 am


Juan Smoes
Admin

Mensajes : 10
Fecha de inscripción : 03/07/2017

Ver perfil de usuario http://111kbj.activo.mx

Volver arriba Ir abajo

Re: ejercicio "la hora"

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Volver arriba

- Temas similares

 
Permisos de este foro:
No puedes responder a temas en este foro.